Hoy se han descubierto y anunciado dos vulnerabilidad que afectan prácticamente a todos los microprocesadores del mundo.

La primera de ellas es Meltdown, un error de seguridad que afecta a los procesadores Intel fabricados durante la ultima década.

El error de seguridad deja al descubierto todo el sistema y deja la puerta abierta a nuestras contraseñas y datos mas confidenciales.

Para solucionar este error se ha preparado una actualización por parte de Intel, un parche llamado Kaiser y que provocara una bajada de rendimiento de entre el 5% y el 30% de los procesadores.

Estas actualizaciones deberán llegar en breve a Windows, macOS y Linux, así que permaneced atentos y actualizar en cuanto os llegue el aviso.

Logos de Mealtdown y Spectre.

Pero eso no es todo, ya que también se ha descubierto una segunda vulnerabilidad, esta afecta  a todos los chips, incluyendo a los ARM y los AMD y  afecta por igual a ordenadores, tablets o smartphones, se trata de Spectre.

Spectre es una vulnerabilidad un tanto mas compleja, tanto su funcionamiento como su solución (por el momento no tiene).

Vamos a intentar explicar esta vulnerabilidad de forma fácil, a día de hoy los procesadores trabajan de con una ejecución especulativa, mediante un algoritmo el procesador intenta predecir cual va a ser tu siguiente orden y la prepara para así ganar en velocidad de reacción, en el caso de que tu orden no sea la que el había predicho simplemente desecha ese código.

Pues con esta vulnerabilidad descubierta hoy un hacker puede ejecutar un código en tu procesador haciéndolo pasar por especulativo, así podría acceder a tus datos y luego ese código seria borrado.

El problema es que a día de hoy no hay una solución frente a este problema, ni se espera poder encontrar una en breve, así que tendremos que convivir con ello.

Interacciones del lector

Deja un comentario